二足歩行ロボットコミュニティサイト

【サイトの使い方】  【サイトマップ】  【お問い合わせ】 
ロボット動画  |   ロボット写真  |   BBS  |   ダウンロード  |   イベント予定  |   スタッフ日記  |   リンク  |  
ログイン パスワード    新規登録   パスワード紛失  

[掲示板に戻る全部  1-  最新50
1 アナログ入力拡張ボードを接続するとスピーカから音が・・・
yasuhiro-o
新米

ono 2008-5-18 15:06  SITE  MAIL  [返信] [編集]

アナログ入力拡張ボードについて質問です

VS-RC003HVとVS-IX008を接続し,
PSDセンサの情報を取り込もうとしています.

VS-RC003HVとVS-IX008は通信は確立していて,
エラーは出ていません.
PSDセンサの情報も反映されています.

しかし,
VS-IX008を接続するとスピーカから「ピー」と音が出ます.
常になっています.
正確に言うと,
VS-RC003HVとスピーカとVS-IX008(単体)だけつないだ状態では
音はなりません.
センサを拡張ボードに接続すると音が出ます.

なぜこんなことになるのでしょう?
接続が悪いんでしょうか?

ファームウェア,RobovieMaker2共に最新版を入れてます.

どのようにしたら解決できるでしょうか?
2 Re: アナログ入力拡張ボードを接続するとスピーカから音が・・・
combat-e
長老

combat-e 2008-5-18 15:58  [返信] [編集]

onoさん、こんにちは(多分お久しぶりです)。

ご質問のノイズ音につきましては、PSDセンサ自体の駆動時のノイズと思われます。
以前より社内でも同様の現象を確認しております。

動作自体にはまったく問題ありません。
3 Re: アナログ入力拡張ボードを接続するとスピーカから音が・・・
yasuhiro-o
新米

ono 2008-5-19 1:58  MAIL  [返信] [編集]

お久しぶりであってます
返信どもです

音ですが,
ノイズ程度ではなくかなり大きな音がします.
なるべくノイズ音を小さくしたいのですが,
どうにかなりませんか?
4 Re: アナログ入力拡張ボードを接続するとスピーカから音が・・・
combat-e
長老

combat-e 2008-5-19 10:45  [返信] [編集]

対処につきましては、下記の方法があるようです。

音の原因に付きまして補足すると、PSDが5Vの電源で動いていて、パルス状の消費電流で、スピーカアンプも同じ5Vで動いているというのが原因のようです。

対策としては以下の二つがあります。

o PSDの電源の両端に電解コンデンサ(100uF〜1000uF)をつける。
o PSDの電源(5V)を何らかの方法で別に作る。

前者は「ある程度ましになるかも」というくらいで、後者はかなり効果はあるかと思いますが、いろいろ改造が面倒になると思われます。

前者の方法については、ロボットユーザの方でも何名かされているようで、ノイズ対策以外にセンサの動作を安定させる効果もある模様です。

また、下記のページも少し参考になるかと思います。
http://www2.denshi.numazu-ct.ac.jp/mirsdoc2/mirs0205/tech/num0014a/PSD.html
5 Re: アナログ入力拡張ボードを接続するとスピーカから音が・・・
yasuhiro-o
新米

ono 2008-5-19 16:32  SITE  MAIL  [返信] [編集]

ノイズが問題なんですね.
了解です.
対策してみます.

ありがとうございました(^^)
[掲示板に戻る全部 次100 最新50
BluesBB ©Sting_Band
検索
メインメニュー